Median XL Technical Requirements - Diablo Wiki

Median XL Technical Requirements


From Diablo Wiki

Jump to: navigation, search

Median XL supports both PC and Mac computers. It is a patch_d2.mpq mod (as opposed to an unpacked -direct -txt mod) which means installation is very easy.

This is what you must have installed in order to play Median XL.

  • the Diablo 2 game
  • the Diablo 2: Lord of Destruction expansion
  • your game installation must be patched to any version from at least 1.10 to 1.12.

Basic FAQ

Q: I have the classic Diablo 2 game, but I don't have the Lords of Destruction expansion, can I still play Median XL?
A: No - Median XL is an expansion game mod.

Q: Will characters from the original game / Median 2008 / [other mods] work in Median XL?
A: No, Median XL uses its own characters.

Q: Will cheats / maphack / bots work with Median XL?
A: No. Median XL is a mod, not godmode.

Q: Is the PlugY addon supported?
A: Yes - see the mini guide section Using PlugY below.

Q: Why don't I see the special effects like shown in the official website screenshots?
A: You must be playing in fullscreen, Direct3D mode.

Q: Is multiplayer supported?
A: Yes. The game's netcode has not been changed in any way. Obviously, the official Blizzard servers don't have the mod installed on them, so you can't play Median XL in closed However, you can still play in open as well as direct TCP/IP mode. Please make sure everyone is using the exact same version of the mod. If you are playing on open, at the very least password-protect your game so that non-mod players will not accidentally join and crash your game.

Using the PlugY addon

PlugY is a very handy addon that enhances your stash by adding "page tabs", so instead of one single stash area, you can flip forward to additional pages and keep more items. The maximum number of pages is 2^32, so for all practical purposes you have near-infinite stash space. What's more, PlugY also allows you to toggle between that character's personal stash, as well as a shared stash which other characters on your computer can access.

NOTE: PlugY has not been updated to support the latest game version (1.12 currently), so keep your upgrade at 1.11b at most. Finally, when using PlugY with Median XL, you need a clean d2gfx.dll - in case you were using a modded version (for example, a multi-instance-enabled one), revert to the original file before you attempt to install PlugY.

When you install PlugY, change the default install-to folder from \Mod PlugY\ up one folder to the main D2 game folder - i.e., instead of \Games\Diablo 2\Mod PlugY\, install to \Games\Diablo 2\. After installation, from now on launch the game using the PlugY executable instead of your old game shortcut. If you did it successfully, you should see PlugY's version information on the lower right side of D2's main menu screen.

PlugY supports many other features. However, the great majority of them are tuned towards "exporting" realm features into singleplayer mode, such as making Ladder runewords available, and activating realms quests. Since Median XL has changed nearly all of those features, trying to activate them may result in character corruption. To avoid losing your characters or breaking your game installation, stick to using the stash features. The good news is the default installation only has the stash features active when you install PlugY after Median XL, so you don't need to do anything else. Just install PlugY and change the game shortcut, and you're all set.

For a summary of features on what the mod changes, check out What is Median XL?
For more detailed information, check out the official FAQ at the source:

Copyright IncGamers Ltd 2016